Hi,

since I'm currently change my rockpro64 setup I came across this.

With the kernel from ayufan you need to set PWM_CTL to

/sys/devices/platform/pwm-fan/hwmon/hwmon3/pwm1

for my self compiled one I need

/sys/devices/platform/pwm-fan/hwmon/hwmon0/pwm1

But I got it only working with one entry for PWM_CTL e.g.

PWM_CTL = "/sys/devices/platform/pwm-fan/hwmon/hwmon0/pwm1",

after that you need to start ats again

sudo systemctl stop ats sudo systemctl start ats

initially the fan should start immediately for a short period of time.

In case it is even a different one on your kernel you can find the right one using this command.

sudo find /sys -name pwm1 | grep hwmon

So far I'm not sure which kernel parameter or modul changes this.

Martin