Intel I350 T4V2


  • administrators

    Es gab welche im Pine64-Forum, die schrieben das diese Karte auf dem ROCKPro64 läuft. Ok, da ich an so einer Karte sehr interessiert bin, mal eben bestellt und eingebaut.

    0_1534361077398_Intel_I350_T4V2_ergebnis.jpg

    Ich bekomme sie leider nicht zum Laufen 😞

    Software

    rock64@rockpro64:~$ uname -a
    Linux rockpro64 4.4.132-1075-rockchip-ayufan-ga83beded8524 #1 SMP Thu Jul 26 08:22:22 UTC 2018 aarch64 GNU/Linux
    

    Treiber

    https://downloadcenter.intel.com/download/13663

    Modul

    Modul gebaut nach Anleitung

    rock64@rockpro64:~$ lsmod
    Module                  Size  Used by
    midgard_kbase         651264  0
    dw_hdmi_i2s_audio      16384  0
    rockchip_saradc        16384  0
    igb                   196608  0
    ip_tables              24576  0
    x_tables               32768  1 ip_tables
    autofs4                40960  0
    phy_rockchip_pcie      16384  0
    

    Wird dann wohl geladen. In /etc/modules eingetragen, damit es beim Start geladen wird.

    Problem

    Wenn ich das Modul entlade und erneut lade, bekomme ich diese Meldung mit dmesg

    [ 1047.587217] Intel(R) Gigabit Ethernet Linux Driver - version 5.3.5.18
    [ 1047.587897] Copyright(c) 2007 - 2018 Intel Corporation.
    

    Das kann nicht alles sein, weil danach die Schnittstellen gesetzt werden müssten.

    Da die Hardware auch nicht wirklich aussieht, als wenn sie lebt. Keine LED leuchtet wenn ich ein Kabel einstecke, kann da was nicht richtig sein. Das Kommando

    sudo lspci -vvv
    

    spuckt auch gar nichts aus. Also scheint die Karte nicht zu funktionieren.

    root@rockpro64:/home/rock64# dmesg | grep -E pcie                
    [    0.504076] of_get_named_gpiod_flags: parsed 'gpio' property of node '/vcc3v3-pcie-regulator[0]' - status (0)
    [    0.504126] reg-fixed-voltage vcc3v3-pcie-regulator: Looking up vin-supply from device tree
    [    0.504165] vcc3v3_pcie: supplied by dc_12v
    [    0.504230] vcc3v3_pcie: 3300 mV 
    [    0.504383] reg-fixed-voltage vcc3v3-pcie-regulator: vcc3v3_pcie supplying 3300000uV
    [    2.040888] vcc3v3_pcie: disabling
    [    2.311600] phy phy-pcie-phy.9: Looking up phy-supply from device tree
    [    2.311617] phy phy-pcie-phy.9: Looking up phy-supply property in node /pcie-phy failed
    [    2.313550] rockchip-pcie f8000000.pcie: GPIO lookup for consumer ep
    [    2.313567] rockchip-pcie f8000000.pcie: using device tree for GPIO lookup
    [    2.313613] of_get_named_gpiod_flags: parsed 'ep-gpios' property of node '/pcie@f8000000[0]' - status (0)
    [    2.314014] rockchip-pcie f8000000.pcie: Looking up vpcie3v3-supply from device tree
    [    2.314148] rockchip-pcie f8000000.pcie: Looking up vpcie1v8-supply from device tree
    [    2.314164] rockchip-pcie f8000000.pcie: Looking up vpcie1v8-supply property in node /pcie@f8000000 failed
    [    2.314200] rockchip-pcie f8000000.pcie: no vpcie1v8 regulator found
    [    2.318356] rockchip-pcie f8000000.pcie: Looking up vpcie0v9-supply from device tree
    [    2.318372] rockchip-pcie f8000000.pcie: Looking up vpcie0v9-supply property in node /pcie@f8000000 failed
    [    2.318399] rockchip-pcie f8000000.pcie: no vpcie0v9 regulator found
    [    2.323371] rockchip-pcie f8000000.pcie: invalid power supply
    [    2.827428] rockchip-pcie f8000000.pcie: PCIe link training gen1 timeout!
    [    2.827625] rockchip-pcie: probe of f8000000.pcie failed with error -110
    root@rockpro64:/home/rock64# 
    

    Zum Vergleich, erfolgreiche Initialisierung der NVMe PCIe Karte.

    rock64@rockpro64v2_0:/sys/class/hwmon/hwmon0$ dmesg | grep -E pcie
    [    0.503626] of_get_named_gpiod_flags: parsed 'gpio' property of node '/vcc3v3-pcie-regulator[0]' - status (0)
    [    0.503677] reg-fixed-voltage vcc3v3-pcie-regulator: Looking up vin-supply from device tree
    [    0.503716] vcc3v3_pcie: supplied by dc_12v
    [    0.503781] vcc3v3_pcie: 3300 mV 
    [    0.503932] reg-fixed-voltage vcc3v3-pcie-regulator: vcc3v3_pcie supplying 3300000uV
    [    2.654296] vcc3v3_pcie: disabling
    [    3.143787] phy phy-pcie-phy.9: Looking up phy-supply from device tree
    [    3.143792] phy phy-pcie-phy.9: Looking up phy-supply property in node /pcie-phy failed
    [    3.190780] rockchip-pcie f8000000.pcie: GPIO lookup for consumer ep
    [    3.190793] rockchip-pcie f8000000.pcie: using device tree for GPIO lookup
    [    3.190867] of_get_named_gpiod_flags: parsed 'ep-gpios' property of node '/pcie@f8000000[0]' - status (0)
    [    3.191154] rockchip-pcie f8000000.pcie: Looking up vpcie3v3-supply from device tree
    [    3.191314] rockchip-pcie f8000000.pcie: Looking up vpcie1v8-supply from device tree
    [    3.191323] rockchip-pcie f8000000.pcie: Looking up vpcie1v8-supply property in node /pcie@f8000000 failed
    [    3.191353] rockchip-pcie f8000000.pcie: no vpcie1v8 regulator found
    [    3.197618] rockchip-pcie f8000000.pcie: Looking up vpcie0v9-supply from device tree
    [    3.197634] rockchip-pcie f8000000.pcie: Looking up vpcie0v9-supply property in node /pcie@f8000000 failed
    [    3.197660] rockchip-pcie f8000000.pcie: no vpcie0v9 regulator found
    [    3.202254] rockchip-pcie f8000000.pcie: invalid power supply
    [    3.262707] PCI host bridge /pcie@f8000000 ranges:
    [    3.280803] rockchip-pcie f8000000.pcie: PCI host bridge to bus 0000:00
    [    3.339349] pcieport 0000:00:00.0: enabling device (0000 -> 0002)
    [    3.350365] pcieport 0000:00:00.0: Signaling PME through PCIe PME interrupt
    [    3.365292] pcie_pme 0000:00:00.0:pcie01: service driver pcie_pme loaded
    [    3.368352] aer 0000:00:00.0:pcie02: service driver aer loaded
    

    Und noch eine merkwürdige Meldung, die ich aber nach Recherche vergessen kann. Soll den Kernel wohl nur als modifiziert flaggen.

    root@rockpro64:/home/rock64# dmesg | grep -E  igb
    [    3.511084] igb: loading out-of-tree module taints kernel.
    

    Ja, ich gebe zu, das ich von dieser Materie so gut wie Null Ahnung habe. Aber auch daran muss man arbeiten 😉

    Irgend jemand eine gute Idee? Oder sieht wo ich was übersehe?


  • administrators

    Dank eines Hinweises gehe ich im Moment davon aus, das die Karte China Müll ist. Die 50$ Karten sollen billige Nachbauten sein. Karte zurück gesendet!