Armbian Image



  • Hi Frank, super und danke für die schnelle Antwort.

    Joa .. die eine oder andere LAMP installation habe ich schon hinter mir 🙂 . Damals noch auf 386ern .. (wobei es hier kein L sondern ein B (BSD) war ... war wohl 1997 oder so ... und der Browser noch ein CLI war ...

    Dein Bild hat etwas von "I/O Porn" :.) ... Habe mir den PCI-E M.2 vorhin schon bestellt .. Hoffe der kommt die Tage an und ich werfe ihm dann mal eine Evo ran ..

    Die / deine gemessenen Werte werden auch mit dem o.g. Armbian Release erreicht ? Für MySQL mit etwas größeren Joins die nicht im Memory gehalten werden, denke ich, dass die PCI-e Lösung als Swap dann besser als ein eMMC Speicher geeignet ist .. ?!



  • Ich habe schon so viel gemessen, das ich nicht mehr weiß was alles noch aktuell ist 🙂

    Die Situation ist aber aktuell recht stabil. Das heißt die Systeme laufen hier sehr gut. Einziges Problem in letzter Zeit war die SATA-Karte, die ich mittlerweile aussortiert habe. Die neue SATA-Karte macht was sie soll.

    Ansonsten läuft hier alles, so wie man es von großen Rootservern kennt. Ok, vielleicht etwas stromsparender 😉

    Aber, gerade im Linuxbereich, hat jeder eine andere Zielrichtung, was er damit machen will. Da kann es natürlich mal vorkommen, das es klemmt.



  • (den Test den ich meinte waren die Unterschiede 960/970er Evi) Danke .. ich werde berichten wie es war, wenn die ersten stress-queries durch sind :- ) .. und jetzt gehts weiter mit dem lustigen image-flashen (da wohl jeder Rockpro64 Neuling erstmal durchgeht 🙂 🙂 )



  • Achja .. und das shutdown -r / reboot problem (undefinierter Zustand danach - bei mir immernoch auf allen Images) habe ich bei mir mit einer Fritz-DECT Fernschalt-Steckdose "gelöst" 🙂 ... (hmmm .. sollte noch nen webhook setzen )



  • Ärgerliches Problem, vor allen Dingen wenn man viel mit den Dingern testet. Aber mittlerweile kennt man das ja 🙂

    Verschiedene Installationen scheinen etwas robuster zu sein, ich denke auch qualitativ hochwertige SD-Karten könnten das Problem verringern. Da stimmt sicherlich noch was nicht mit den Timings und Frequenzen!?

    Ok, Steckdose geht immer 🙂



  • hmm .. gestern ca. 6 verschiedenste SD Karten 2, 4, 6 , 16, 32 GB ... im Einsatz gehabt und einmal --- ein einzigstes mal hat er ge-rebootet ... (ich weiss jedoch nicht mehr welche es war ... )

    eine superaktuelle 32 GB Sandisk supi-dupi Karte die ich gerade im Einsatz habe will nicht rebooten ... .. btw. das armbian stretch image ist auf den ersten, schnellen blick mein tages-favorit (so darf man es wohl titulieren 😉 ) ..



  • ps ... aktuelles nightly build .173 🙂

    Welcome to ARMBIAN 5.74.190202 nightly Debian GNU/Linux 9 (stretch) 4.4.173-rock



  • entschuldigung,
    was war nochmal das reboot-problem? kenne ich gar nicht



  • Es gab/gibt verschiedene Konfigurationen, wo ein

    sudo reboot
    

    dazu geführt hat, das das System nicht jedesmal durchstartet. Manchmal blieb es unkontrolliert hängen.

    Hier der Thread im Pine64-Forum https://forum.pine64.org/showthread.php?tid=6785

    Eine mögliche Ursache sind Timingprobleme, warum es dann aber immer bei einem Kaltstart geht - keine Ahnung. Scheint evt. auch am u-boot zu liegen, gibt viele Spekulationen. Ich hatte aber auch schon Systeme, wo das nie ein Problem war. Also alles sehr merkwürdig. Eben mal ein paar Reboots gemacht mit dem neuen Mainline vom Kamil.

    Welcome to Ubuntu 18.04.1 LTS (GNU/Linux 4.20.0-1088-ayufan-gaac9b4fce0ab aarch64)
    

    Was soll ich sagen, er hat jedesmal durchgestartet 🙂 Ich habe mich mittlerweile dran gewöhnt, kenne die Zeit nach dem der ROCKPro64 mit dem Booten fertig sein muss 😉



  • ah ok, danke.
    hab hier eine emmc am laufen (die war noch irgendwo über), habe auch nicht soo viel zeit mit 4.4er und ayufan mainline am laufen gehabt. auch in dieser richtung trotzdem bislang keinen ärger gehabt.



  • Moin.
    Ich bin Christoph und hier neu im Forum. Ich habe einen RockPro64 bestellt und möchte mit nem Armbian Image loslegen, aber gerne mit Kernel 4.20
    Ich kenne mich grundsätzlich mit Linux aus, aber vielleicht helfen mir ein paar Tipps wie ich den Kernel upgraden kann?
    Mein Ziel ist es ein 4x HDD NAS, wo das OS von mircroSD läuft, sowie ein Webserver auf dem eMMC.

    Hoffe man kann mir helfen?

    Gruß,
    Christoph



  • Hallo Christoph,

    Amrbian hat, meines Wissens nach, aktuell keinen 4.20 Kernel. Den kann man sicher da einbauen, wenn man weiß wie 😉 Ich weiß es so spontan nicht.

    Alternativ kannst du Kamil seine Images nehmen. Der Kerl nennt sich im Netz Ayifan und kommt aus Polen, macht aber eine gute Arbeit 🙂 Dort steht dir aktuell ein 4.20.0-1090-ayufan zur Verfügung.

    Ich kann die Images eigentlich nur empfehlen. Wenn du dabei Hilfe brauchst, stell einfach Deine Fragen...

    Vorschlag, du könntest alternativ das System und den Webserver auf einer SSD am USB3-Port laufen lassen. Wird sicherlich mehr Spaß machen als auf SD-Karte oder eMMC.



  • @FrankM danke für die schnelle Antwort.
    Ich habe ne microSD Standard U3 in Planung, die sollte das von der Geschwindigkeit schon wuppen.

    Ich probiere dann Mal ein Armbian Image und den Kernel dort reinzubringen... Mal schauen was Google dazu meint.



  • @cnaed , halte uns auf dem Laufenden.



  • Klar mache ich, nur dauert es sicher bis die Teile alle ankommen. Von daher denke ich das ich alles Ende März was berichten kann.



  • In der Zwischenzeit verweise ich gerne auf Kamil's 5.0 Kernel 😉

    https://github.com/ayufan-rock64/linux-mainline-kernel/releases


Log in to reply
 

Diese Artikel könnten Dich auch interessieren.

  • 3
  • 1
  • 1
  • 4
  • 2
  • 2
  • 1

  • Linux  

    1