Armbian Image



  • Es gab/gibt verschiedene Konfigurationen, wo ein

    sudo reboot
    

    dazu geführt hat, das das System nicht jedesmal durchstartet. Manchmal blieb es unkontrolliert hängen.

    Hier der Thread im Pine64-Forum https://forum.pine64.org/showthread.php?tid=6785

    Eine mögliche Ursache sind Timingprobleme, warum es dann aber immer bei einem Kaltstart geht - keine Ahnung. Scheint evt. auch am u-boot zu liegen, gibt viele Spekulationen. Ich hatte aber auch schon Systeme, wo das nie ein Problem war. Also alles sehr merkwürdig. Eben mal ein paar Reboots gemacht mit dem neuen Mainline vom Kamil.

    Welcome to Ubuntu 18.04.1 LTS (GNU/Linux 4.20.0-1088-ayufan-gaac9b4fce0ab aarch64)
    

    Was soll ich sagen, er hat jedesmal durchgestartet 🙂 Ich habe mich mittlerweile dran gewöhnt, kenne die Zeit nach dem der ROCKPro64 mit dem Booten fertig sein muss 😉



  • ah ok, danke.
    hab hier eine emmc am laufen (die war noch irgendwo über), habe auch nicht soo viel zeit mit 4.4er und ayufan mainline am laufen gehabt. auch in dieser richtung trotzdem bislang keinen ärger gehabt.



  • Moin.
    Ich bin Christoph und hier neu im Forum. Ich habe einen RockPro64 bestellt und möchte mit nem Armbian Image loslegen, aber gerne mit Kernel 4.20
    Ich kenne mich grundsätzlich mit Linux aus, aber vielleicht helfen mir ein paar Tipps wie ich den Kernel upgraden kann?
    Mein Ziel ist es ein 4x HDD NAS, wo das OS von mircroSD läuft, sowie ein Webserver auf dem eMMC.

    Hoffe man kann mir helfen?

    Gruß,
    Christoph



  • Hallo Christoph,

    Amrbian hat, meines Wissens nach, aktuell keinen 4.20 Kernel. Den kann man sicher da einbauen, wenn man weiß wie 😉 Ich weiß es so spontan nicht.

    Alternativ kannst du Kamil seine Images nehmen. Der Kerl nennt sich im Netz Ayifan und kommt aus Polen, macht aber eine gute Arbeit 🙂 Dort steht dir aktuell ein 4.20.0-1090-ayufan zur Verfügung.

    Ich kann die Images eigentlich nur empfehlen. Wenn du dabei Hilfe brauchst, stell einfach Deine Fragen...

    Vorschlag, du könntest alternativ das System und den Webserver auf einer SSD am USB3-Port laufen lassen. Wird sicherlich mehr Spaß machen als auf SD-Karte oder eMMC.



  • @FrankM danke für die schnelle Antwort.
    Ich habe ne microSD Standard U3 in Planung, die sollte das von der Geschwindigkeit schon wuppen.

    Ich probiere dann Mal ein Armbian Image und den Kernel dort reinzubringen... Mal schauen was Google dazu meint.



  • @cnaed , halte uns auf dem Laufenden.



  • Klar mache ich, nur dauert es sicher bis die Teile alle ankommen. Von daher denke ich das ich alles Ende März was berichten kann.



  • In der Zwischenzeit verweise ich gerne auf Kamil's 5.0 Kernel 😉

    https://github.com/ayufan-rock64/linux-mainline-kernel/releases



  • Hi @FrankM ,

    ich hole heute meinen rockpro64 mit 4gb, NAS-Gehäuse und PCIe-Sata Extension endlich von der Post ab 🙂

    Geplant habe ich das als reines NAS, mit ein paar Extras (Plex, openhab). Betrieben wird das ganze mit einer 128gb U3 SSD, sowie vorerst einer 3tb 3,5" HDD. Zusätzlich wird es wohl noch eine Backup-Platte via USB3 geben (2,5" HDD). Netzteil habe ich mir das hoffentlich ausreichende 5A mitbestellt.

    Insofern stelle ich mir die Frage welches Image ich verwenden sollte. Ich würde gerne hierfür das offizielle Armbian installieren (4.4er Server). Spricht etwas gegen Armbian, bzw. wäre z.B. das "stretch-minimal-rock64-0.9.14-1159-arm64.img.xz" von ayufan die bessere Wahl?

    Danke dir.

    Grüße,
    Flow



  • Hallo @flow77 ,

    ich denke mit den 4.4er kannst du bei beiden nichts falsch machen. Bitte aber drauf achten, das richtige Image runterzuladen.

    https://github.com/ayufan-rock64/linux-build/releases/download/0.9.14/stretch-minimal-rockpro64-0.9.14-1159-arm64.img.xz

    Kein rock64 ! Dann klappt auch das Booten 😉

    Wenn du jetzt nicht einen besonderen Grund für Stretch hast, würde ich auf Buster setzen.
    https://github.com/ayufan-rock64/linux-build/releases/download/0.9.14/buster-minimal-rockpro64-0.9.14-1159-arm64.img.xz

    Viel Spaß! Und wenn Du möchtest, berichte mal wie es so läuft.



  • Hi @FrankM ,

    danke dir. Richtig, falschen Link zum Ayufan-Image gepostet.

    Ich bin gerade am ersten Testen mit dem 4.4er Armbian. Auf den ersten Blick scheint alles gut zu laufen. Positiv ist mir gleich einmal die I/O aufgefallen (128gb Samsung Evo Plus), offensichtlich kann man diese gut ausreizen. Zudem bin ich ebenso vom armbian-config begeistert, Plex und OMV laufen prima. Bis jetzt hab ich mich mit armbian eher mit nanopi&co herumgeschlagen, wo das kein Thema war.

    Leider habe ich offensichtlich vergessen die PCIe-Sata mitzubestellen, insofern musste ich mir nun eine beim großen A bestellen.

    Ich berichte dann gerne ausführlich darüber sobald bei mir alles läuft.

    Grüße,
    Flow


Log in to reply
 

Diese Artikel könnten Dich auch interessieren.

  • 2
  • 1
  • 1
  • 4
  • 2
  • 3
  • 1

  • Linux  

    1