UNSOLVED ROCKPRO64 Serial Port Pins


  • I have a ROCKPro64 v2.1 board and installed with "bionic-minimal-rockpro64-0.8.0rc6-1111-armhf.img". The system boots up is fine, but both /dev/ttyS0 and /dev/ttyS2 are not working. I don't know which pins out of a total 40 pins of Pi-2 are for UART 0 (/dev/ttyS0). Am I correct that Pin 8 is /dev/ttyS2 Tx Pin and Pin 10 is /dev/ttyS2 Rx Pin? Are these UART pins are enabled by default after system boot up? Should I do something to enable these pins in order for UART (/dev/ttyS0 or /dev/ttyS2) to work?

    For a UART to work, I mean this ttyS0 or ttyS2 port is able to send out or receive characters. Currently, I am able to open and set up serial port but not able to send out or receive characters correctly. I guess those UART pins are shared with GPIO pins or multiplexed with GPIO functionality, some configurations may need to be done. Could you help me?


  • Hello @xwang2019 ,

    please read this post -> https://forum.frank-mankel.org/topic/53/serielle-konsole-uart2 (german)

    • Nr. 6 GND - schwarz
    • Nr. 8 UART2_TX - weiß
    • Nr. 10 UART2_ RX - grün

    With my adapter i must removed pin no. 10. With this connection i can't boot properly.

    This uart connection is enabled by default in all images from ayufan.

    I hope this will help you. And excuse my english isn't the best 😉


  • Hi FrankM,

    Thank you very much for your help. The objective of my task is to find a UART serial port (ttyS0 or ttyS2) to substitute ttyUSB0 port on ROCKPro64. I found out yesterday by reading through the schematics of ROCKPro64 v2.1 that UART0 (ttyS0) and UART2 (ttyS2) are NOT a general RS232 serial port on ROCKPro64. UART0 (ttyS0) is now connected with the Bluetooth device on ROCKPro64. UART2 (ttyS2) is now connected to Debug Port and used as a console serial port. I need to disconnect UART0 with Bluetooth device to get ttyS0 back.

    Xiaoming


  • I think i understood 🙂

    You can use an image before 0.7.13

    0.7.13: Enable support for RockPro64 WiFi/BT module,
    

    Is that an option for you?

    Or you edit the dts file with

    sudo dtedit
    

    Remove all entries for uart0 and copy entries from image before 0.7.13 🤔

    Last but not least, ask ayufan 🙂


  • Hi FrankM,

    Thank you very much for your help. I tried 0.7.9 image. ttyS0 doesn't work even when WiFI/BT module is disabled. Because I don't need WiFi/BT option, I am going to edit the dts file. Could you let me to know the following steps after dts file got modified? Thanks.

    Regards,

    Xiaoming