ROCKPRO64 langsames SMB



  • Hi,
    ich habe mir auch einen ROCKPRO64 zugelegt und versuche damit ein NAS ans laufen zu bringen. Als Datenplatte habe ich eine WD Blue 5TB angeschlossen. Leider bekomme ich über SMB nur ca. 11MB/s beim schreiben. Ich habe angefangen mit OpenMediaVault, danach dietpi und zuletzt Armbian_5.88_Rockpro64_Debian_stretch_default_4.4.180, komme aber nicht über 11MB/s raus.
    Hast du vielleicht ein paar Tips für mich?

    Gruss Timo



  • Willkommen @TimoW

    An welcher Schnittstelle ist die Platte angeschlossen?



  • Hallo Frank,
    die Platte ist an der SATA Karte von Pine angeschlossen.

    Gruss Timo



  • Ich habe noch etwas weiter getestet. Auf die interne SD-Card auch nur 11MB/s genauso wie auf eine 1TB NVME SSD.

    iperf sagt folgendes:
    [ ID] Interval Transfer Bandwidth Retr
    [ 4] 0.00-10.00 sec 115 MBytes 96.6 Mbits/sec 0 sender
    [ 4] 0.00-10.00 sec 113 MBytes 95.0 Mbits/sec receiver

    und ein speed test per dd bringt:
    1073741824 bytes (1.1 GB, 1.0 GiB) copied, 3.22124 s, 333 MB/s



  • tach,
    was bei mir in der smb.conf so rum steht bzw. stand:

    # Speed tuning
    # See http://lug.krems.cc/docu/samba/appb_02.html
    #
    # without the socket options, it's working similar, no visible gain
    #socket options = IPTOS_LOWDELAY TCP_NODELAY SO_KEEPALIVE SO_RCVBUF=65536 SO_SNDBUF=65536 
    socket options = IPTOS_LOWDELAY TCP_NODELAY SO_KEEPALIVE
    #oplocks = yes                      # Use caching at all files. This one boosts
    #max xmit = 65535
    #dead time = 15
    #getwd cache = yes
    
    

    ggf kannst auch mal schauen, welches cifs/smb im kernel deiner wahl bzw beim mounten in benutzung ist, da gibt's so smb dialekte, und die neueren sind wohl fixer

    gruß



  • Wie man hier sieht, sind die technischen Voraussetzungen für bessere Schreibraten gegeben.

    Da ich kein Samba nutze, kann ich dazu nicht so richtig viel schreiben. Ich nutze nur NFS, weiß aber das das nicht für alle eine Alternative ist. Also zurück zu Samba.

    Zwei Dinge, die mir dazu einfallen. Das System läuft von der SD-Karte? Das ist ein Flaschenhals. Das System auf die NVMe umlegen, so das wir die Daten auch mit voller Geschwindigkeit schreiben können. Die SD-Karte wird dann nur noch für den Startvorgang genutzt.

    Und evt.

    Edit your conf:
    [global]
    min protocol = SMB2

    Then, systemctl restart smbd.service
    Quelle: https://forum.pine64.org/showthread.php?tid=6844&highlight=samba

    Viel Erfolg.



  • Auch ein Umzug des Systems auf NVME hat keine Besserung gebracht.
    Mir ist noch aufgefallen, das Lesen über SMB auch nur mit max. 11MB/s läuft.



  • Dann sollte es wohl definitiv am Samba liegen. Nur wo und warum?? Ich muss da passen. Liest sich bei dir so, als wenn die Bandbreite irgendwo auf 11MB/s limitiert ist.

    Vielleicht mal im IRC oder im Forum direkt nachfragen.



  • Das ganze war doch simpler als gedacht. Nach Austausch des Netzwerkkabel bekomme ich jetzt problemlos über 100MB/s



  • Wow, manchmal sind es die Dinge wo man nicht dran denkt 🙂

    Danke für's Feedback! Und nun viel Spaß!


Log in to reply
 

Diese Artikel könnten Dich auch interessieren.

  • 5
  • 3
  • 11
  • 3
  • 3
  • 12
  • 16
  • 8