Proxmox - VE 6.0-4



  • Durch den neuen Ryzen hatte ich ein wenig Hardware über 🙂 Die Preise, die man mir angeboten hatte, erzeugten bei mir das Gefühl etwas zu verschenken. Also habe ich beschlossen, die "alte" Kiste erst mal zu behalten. Zu diesem Zeitpunkt, hatte ich schon einen Plan im Kopf, was ich damit machen möchte.

    Hardware

    • MSI B350 Gaming Plus
    • AMD Ryzen 5 1600 (Sechs Cores, 12 Threads)
    • 16GB RAM
    • 500GB PCIe NVMe SSD
    • 240GB SSD SATA

    IMG_20190714_144731_800.jpg

    Software

    Installation

    Image ab auf den USB-Stick und das System gestartet. Ruckzuck war Proxmox auf der Kiste. Nach ein wenig umschauen, erstes Problem, wie füge ich eine HDD/SSD als Speicher dazu!?

    Unter Knoten/Disks sieht man die Festplatten. Dort kann man die Festplatte auswählen, dann auf Initialisiere mit GPT, danach ist die Platte einsatzbereit. Unter Disk/LVM-Thin auf Erstellen Thinpool klicken, Festplatte auswählen und Namen vergeben - fertig!

    42c08882-464d-4b4d-a1cb-b4b1f0b82ed7-grafik.png

    Virtuelle Maschine erstellen (VM)

    Nächster Step wäre dann wohl mal eine VM (Virtuelle Maschine) zu erstellen. Aber, da kommt ein Problem auf. Wie lade ich ein Image hoch!? Dazu klicken wir auf local

    af656cad-a360-42ad-a112-71e8a8ab5770-grafik.png

    Danach auf Hochladen, Image auswählen und ab auf die Maschine 🙂

    Jetzt können wir eine VM erstellen.Rechts oben auf Erstelle VM klicken. Ich gehe jetzt hier mal nicht auf die Einstellungen ein, ich hatte also so weit alles ausgewählt und eingestellt. Danach war die VM fertig. Beim Start der VM kam aber ein Fehler 😞

    TASK ERROR: KVM virtualisation configured, but not available. Either disable in VM configuration or enable in BIOS.
    

    Gut, das scheint einfach zu sein. Proxmox runtergefahren, ab ins BIOS. Suchen....suchen......aaahhhhh! Nennt sich auf dem Board SVM Mode (Secure Virtual Machine Mode). Eingeschaltet, Neustart, VM gestartet - Läuft!!

    Firewall

    Später im Netz muss ja zwingend eine Firewall auf der Kiste laufen. Dazu auf Rechenzentrum/Firewall/Optionen Hier kann man mit einem Klick auf Firewall, die Firewall einschalten! klicken.

    Achtung! Sperrt Euch nicht aus.

    Es kann nicht schaden, eine offene SSH aufrecht zu erhalten. Standardmäßig ist das Webinterface und der SSH Zugang aber wohl offen. Ich habe da im iptables Regeln für gefunden. Das ist aber bei den VM's nicht der Fall, hier ist alles zu.Dort muss man sich also erst den SSH-Port freischalten. Vorher die Firewall einschalten und dann folgendes eingeben.

    c55ef031-9ebd-4cc7-abe4-7a817dcdc816-grafik.png

    Danach kann man sich per SSH mit der VM verbinden. Ich gehe hier nicht weiter auf Sicherheit im Netz ein, draußen sieht das alles was anders aus. Hier zum Testen muss das im Moment reichen.

    bf60f345-7327-4e21-8b0d-8dc9778825bb-grafik.png

    Irgendwie gefällt mir das 🙂 Aber, ich stehe da erst ganz am Anfang!!


Log in to reply
 

Diese Artikel könnten Dich auch interessieren.

  • 2
  • 4
  • 1
  • 2
  • 5
  • 2