ROCKPro64 - Secondary IP entfernen



  • Eben festgestellt, das mein NAS noch mit einem Ubuntu lĂ€uft. Damit es hier einheitlich ist, soll das weg 🙂
    DafĂŒr bin ich gerade ein neues System am Aufsetzen. Dabei ist mir was aufgefallen, auch frĂŒher schon, aber diesmal soll das weg!

    Image

    Linux rockpro64 4.4.190-1233-rockchip-ayufan-gd3f1be0ed310 #1 SMP Wed Aug 28 08:59:34 UTC 2019 aarch64
    

    Aktualisiert auf Debian Buster 10.1

    Problem

    rock64@rockpro64:~$ ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host 
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
        link/ether 62:03:b0:d6:dc:b3 brd ff:ff:ff:ff:ff:ff
        inet 192.168.3.2/24 brd 192.168.3.255 scope global dynamic eth0
           valid_lft 7191sec preferred_lft 7191sec
        inet 192.168.3.4/24 brd 192.168.3.255 scope global secondary noprefixroute eth0
           valid_lft forever preferred_lft forever
        inet6 2a02:908:1266:9690:xxxxxxxxxxxxxxxxxx/64 scope global dynamic mngtmpaddr noprefixroute 
           valid_lft 7189sec preferred_lft 589sec
        inet6 fe80::6003:b0ff:fed6:dcb3/64 scope link 
           valid_lft forever preferred_lft forever
    

    Ich habe auf der LAN-Schnittstelle zwei IP-Adressen.

    inet 192.168.3.2/24 brd 192.168.3.255 scope global dynamic eth0
    inet 192.168.3.4/24 brd 192.168.3.255 scope global secondary noprefixroute eth0
    

    Die secondary brauch ich nicht. Ok, ein wenig gegoogelt und dann folgendes eingegeben.

    systemctl stop dhcpcd
    systemctl disable dhcpcd
    

    Danach neustarten

    reboot
    

    Dann schauen wir mal nach.

    rock64@rockpro64:~$ ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host 
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
        link/ether 62:03:b0:d6:dc:b3 brd ff:ff:ff:ff:ff:ff
        inet 192.168.3.2/24 brd 192.168.3.255 scope global dynamic eth0
           valid_lft 7193sec preferred_lft 7193sec
        inet6 2a02:908:1266:9690:xxxxxxxxxxxxxxx/64 scope global dynamic mngtmpaddr 
           valid_lft 7198sec preferred_lft 598sec
        inet6 fe80::6003:b0ff:fed6:dcb3/64 scope link 
           valid_lft forever preferred_lft forever
    

    Gut, sie ist weg 😉

    Warum das so ist, weiß ich nicht. FĂŒr mich macht ein dhcpd da aktuell keinen Sinn!?!? Ich möchte ja keinen Clients Adressen zuteilen. Wenn ich völlig daneben liege, bitte ich um Korrektur.



  • Hoppla, etwas aus der Übung. Mit dem letzten Release 0.9.16 gibt es dieses Problem nicht mehr.

    Das scheint nicht immer der Fall zu sein!

    Gerade nach einer Neuinstallation schon wieder zwei IP-Adressen.


Log in to reply
 

Diese Artikel könnten Dich auch interessieren.

  • 1
  • 4
  • 5
  • 1
  • 1
  • 3
  • 3
  • 5