Kopia - Error 405



  • Ich hatte die Tage ein paar Probleme, mich zu meinem Repository Server zu verbinden, weil ich ein Zeichen zu viel drin hatte 😞

    Falsch

    USER@DOMAIN:~$ kopia repo connect server --url=https://DOMAIN:51515/ --override username=USER --override-hostname=DOMAIN
    Enter password to open repository: 
    
    kopia: error: server error: 405 Method Not Allowed, try --help
    

    Richtig

    USER@DOMAIN:~$ kopia repo connect server --url=https://DOMAIN:51515 --override-username=USER --override-hostname=DOMAIN
    Enter password to open repository: 
    
    Connected to repository API Server.
    
    NOTICE: Kopia will check for updates on GitHub every 7 days, starting 24 hours after first use.
    To disable this behavior, set environment variable KOPIA_CHECK_FOR_UPDATES=false
    Alternatively you can remove the file "/home/frank/.config/kopia/repository.config.update-info.json".
    

    Könnt ihr hier nachlesen.

    Aber, ich habe wieder etwas gelernt und zwar durch eine Antwort von Jarek

    Web UI and CLI share the same configuration files. When you do ‘repo connect’ in CLI it creates repository.config file which persists the location of the repository. When you connect to repo in Web UI does exactly the same thing.

    When you click Disconnect it removes configuration file (it’s equivalent to kopia repo disconnect).

    Dadurch bleibt eine bestehende Verbindung dauerhaft. Nach einem Reboot kann ich sofort

    kopia snapshot create $HOME
    

    ausführen. Das erklärt auch, warum ich , wenn ich KopiaUI auf dem Desktop starte, sofort zu einem Repository verbunden bin.

    Bild Text


Log in to reply
 

Diese Artikel könnten Dich auch interessieren.

  • 1
  • 1

  • NGINX  

    1

  • Linux  

    5
  • 2
  • 1
  • 3
  • 1