NanoPi R2S



  • Zunächst wollte ich den NanoPi R2S in einem deutschen Shop bestelle. Er stand dort auf 29 Tagen Lieferzeit. Ok, da es nicht eilte habe ich ihn dann bestellt. Er sollte dort übrigens viel mehr Kosten als in China. Ja, ich weiß Steuern usw.

    Bezahlt mit PayPal. Einige Tage später erreicht mich dann ein Mail, das man die Bestellung storniert hat. Das Geld wurde prompt zurückgezahlt.

    Ja, so kann man Geschäfte machen, ich werde diesen Laden aber in Zukunft komplett meiden.

    Nun gut, dann bestelle ich halt direkt beim Hersteller in China. Das mache ich nur, wenn diese Shops DHL Service anbieten. Das erspart einem meist die Lauferei zum Zoll usw.

    Am 14. September bezahlt, gestern am 21. September lag die Sendung im Briefkasten. Das die sich den DHL Service richtig gut bezahlen lassen, brauche ich nicht erwähnen. Das sind ca. 21$.

    Beschreibung Stückpreis Anzahl Betrag
    NanoPi R2S
    Artikelnr. R2S Purchase Combination: No, thank you
    Product Option: Combo with Metal Cas. $28,00 USD 1 $28,00 USD
    Shipping, Handling, Discounts & Taxes
    $20,69 USD 1 $20,69 USD

    Insgesamt habe ich €42,94 EUR bezahlt.

    Dann schauen wir mal, was man dafür bekommt 🙂

    IMG_20200921_160513_ergebnis.jpg

    Lieferung

    Erfolgt gut verpackt in einem Karton. Darin ein kleines Aluminiumgehäuse mit der montierten Platine des R2S. Das Gehäuse ist ca. 606028mm groß!

    Herstellerfoto

    R2S_01-900x630.jpg
    Quelle: https://www.friendlyarm.com/

    Spezifikation NanoPi R2S

    Funktion Typ Bemerkung
    CPU
    CPU Rockchip RK3328
    Kerne Quad-Core Cortex-A53
    Frequenz 4 x Cortex-A53 Up to 1.3GHz
    RAM
    DDR4 RAM 1GB
    Netzwerk
    LAN1 Internal 10/100/1000M Ethernet Port x 1
    LAN2 USB3.0 converted 10/100/1000M Ethernet Port x 1

    Dazu noch ein USB2-Port, Reset, drei LEDs, ein SD-Karten Slot und eine serielle Schnittstelle.

    Quelle

    Software

    Ich habe mich jetzt bei der bekannten Quelle https://armbian.com/nanopi-r2s/ bedient. Dort gibt es zwei Images.

    • Armbian Focal - ein Ubuntu Focal basierend auf Kernel 5.8
    • Armbian Debian - ein Debian Buster basierend auf Kernel 5.8

    Dann mal das Debian auf die SD-Karte und das Ding gestartet. Nach kurzer Zeit blinkt die rote LED, ein Heartbeep des Systems. Ok, da der R2S keine Bildschirmausgabe hat, gibt es zwei Möglichkeiten.

    • Serielle Console (UART)
    • per SSH

    Da ich das Gehäuse im Moment nicht aufschrauben möchte, greife ich zu einer SSH Verbindung.
    Das hier sehe ich nach dem 2. Booten!

    frank@:~$ ssh root@192.168.3.8
    root@192.168.3.8's password: 
     _   _                         _   ____  ____  ____  
    | \ | | __ _ _ __   ___  _ __ (_) |  _ \|___ \/ ___| 
    |  \| |/ _` | '_ \ / _ \| '_ \| | | |_) | __) \___ \ 
    | |\  | (_| | | | | (_) | |_) | | |  _ < / __/ ___) |
    |_| \_|\__,_|_| |_|\___/| .__/|_| |_| \_\_____|____/ 
                            |_|                          
    Welcome to Armbian 20.08.1 Buster with Linux 5.8.6-rockchip64
    
    System load:   0.29 0.14 0.05  	Up time:       1 min		
    Memory usage:  11 % of 979MB  	IP:            192.168.3.8
    192.168.3.12 169.254.7.228
    CPU temp:      40°C           	
    Usage of /:    5% of 29G    	
    
    [ General system configuration (beta): armbian-config ]
    
    Last login: Mon Sep 21 19:43:07 2020 from 192.168.3.213
    

    Warum erwähne ich das mit dem 2. Booten hier? Wir haben auf der WAN Schnittstelle zwei IP Adressen!

    root@nanopi-r2s:~# ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host 
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether b2:b5:10:38:9e:76 brd ff:ff:ff:ff:ff:ff
        inet 192.168.3.8/24 brd 192.168.3.255 scope global dynamic noprefixroute eth0
           valid_lft 4996sec preferred_lft 4996sec
        inet 192.168.3.12/24 brd 192.168.3.255 scope global secondary dynamic eth0
           valid_lft 4997sec preferred_lft 4997sec
        inet6 2a02:908:1268:1d50:7ff5:40d8:a538:4e7c/64 scope global dynamic noprefixroute 
           valid_lft 7170sec preferred_lft 570sec
        inet6 fe80::e3d3:fd49:8778:aa19/64 scope link noprefixroute 
           valid_lft forever preferred_lft forever
    3: lan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
        link/ether b2:b5:10:38:9e:96 brd ff:ff:ff:ff:ff:ff
        inet 169.254.7.228/16 brd 169.254.255.255 scope link lan0:avahi
           valid_lft forever preferred_lft forever
    

    Nennt sich Secondary IP und gibt es auch auf dem ROCKPro64. Finde das immer sehr nervig und schalte das immer ab.

    Außerdem leuchtet ab dem 2. Booten die grüne LED LAN, obwohl mein Netzwerkkabel in der Buchse WAN eingesteckt ist? 🤔 Das muss noch untersucht werden!

    Ok, beim 1. Booten kam noch das hier

    WARNING: Unknown X keysym "dead_belowmacron"
    

    War mir völlig neu, habe dem Armbian Team das mal mitgeteilt.

    Und jetzt noch kurz ein

    iperf3 Test

    root@nanopi-r2s:~# iperf3 -c 192.168.3.213
    Connecting to host 192.168.3.213, port 5201
    [  5] local 192.168.3.8 port 49442 connected to 192.168.3.213 port 5201
    [ ID] Interval           Transfer     Bitrate         Retr  Cwnd
    [  5]   0.00-1.00   sec   106 MBytes   893 Mbits/sec    0   2.03 MBytes       
    [  5]   1.00-2.00   sec   112 MBytes   944 Mbits/sec    0   2.15 MBytes       
    [  5]   2.00-3.01   sec  92.5 MBytes   772 Mbits/sec   10   1.08 MBytes       
    [  5]   3.01-4.01   sec  93.8 MBytes   782 Mbits/sec    1   1.08 MBytes       
    [  5]   4.01-5.01   sec  92.5 MBytes   780 Mbits/sec    1   1.08 MBytes       
    [  5]   5.01-6.00   sec  92.5 MBytes   781 Mbits/sec    0   1.08 MBytes       
    [  5]   6.00-7.01   sec  93.8 MBytes   780 Mbits/sec    0   1.08 MBytes       
    [  5]   7.01-8.00   sec  92.5 MBytes   779 Mbits/sec   11    550 KBytes       
    [  5]   8.00-9.01   sec  93.8 MBytes   780 Mbits/sec    0    550 KBytes       
    [  5]   9.01-10.01  sec  92.5 MBytes   781 Mbits/sec    1    550 KBytes       
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ ID] Interval           Transfer     Bitrate         Retr
    [  5]   0.00-10.01  sec   963 MBytes   807 Mbits/sec   24             sender
    [  5]   0.00-10.01  sec   963 MBytes   807 Mbits/sec                  receiver
    
    iperf Done.
    root@nanopi-r2s:~# iperf3 -R -c 192.168.3.213
    Connecting to host 192.168.3.213, port 5201
    Reverse mode, remote host 192.168.3.213 is sending
    [  5] local 192.168.3.8 port 49446 connected to 192.168.3.213 port 5201
    [ ID] Interval           Transfer     Bitrate
    [  5]   0.00-1.00   sec   108 MBytes   906 Mbits/sec                  
    [  5]   1.00-2.00   sec   112 MBytes   941 Mbits/sec                  
    [  5]   2.00-3.00   sec   112 MBytes   942 Mbits/sec                  
    [  5]   3.00-4.00   sec   112 MBytes   941 Mbits/sec                  
    [  5]   4.00-5.00   sec   112 MBytes   942 Mbits/sec                  
    [  5]   5.00-6.00   sec   112 MBytes   942 Mbits/sec                  
    [  5]   6.00-7.00   sec   112 MBytes   941 Mbits/sec                  
    [  5]   7.00-8.00   sec   112 MBytes   942 Mbits/sec                  
    [  5]   8.00-9.00   sec   112 MBytes   941 Mbits/sec                  
    [  5]   9.00-10.00  sec   112 MBytes   942 Mbits/sec                  
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ ID] Interval           Transfer     Bitrate         Retr
    [  5]   0.00-10.01  sec  1.09 GBytes   940 Mbits/sec    0             sender
    [  5]   0.00-10.00  sec  1.09 GBytes   938 Mbits/sec                  receiver
    
    iperf Done.
    

    Was könnte man denn nun damit anfangen? Als erstes fällt mir dazu dann folgendes ein

    • Mobile Firewall 😀

    Ich werde berichten....



  • So, mal ein wenig gespielt 🙂

    Vorlage -> https://forum.frank-mankel.org/topic/201/rockpro64-firewall-mit-zwei-lan-schnittstellen

    Eine der Schnittstellen ist an den USB Bus angeschlossen

    root@nanopi-r2s:/var/log# lsusb
    Bus 005 Device 002: ID 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter
    Bus 005 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    

    Versuchsaufbau

    • Notebook an LAN
    • Mein Netzwerk an WAN

    iperf3 Server auf meinem Haupt-PC. iperf3 Client auf dem Notebook.

    frank@thinkpad:~$ iperf3 -c 192.168.3.213
    Connecting to host 192.168.3.213, port 5201
    [  5] local 192.168.0.100 port 59526 connected to 192.168.3.213 port 5201
    [ ID] Interval           Transfer     Bitrate         Retr  Cwnd
    [  5]   0.00-1.00   sec  63.3 MBytes   531 Mbits/sec   28   1.30 MBytes       
    [  5]   1.00-2.00   sec  68.8 MBytes   577 Mbits/sec    0   1.44 MBytes       
    [  5]   2.00-3.00   sec  68.8 MBytes   577 Mbits/sec    0   1.55 MBytes       
    [  5]   3.00-4.00   sec  70.0 MBytes   587 Mbits/sec    0   1.63 MBytes       
    [  5]   4.00-5.00   sec  68.8 MBytes   577 Mbits/sec    0   1.69 MBytes       
    [  5]   5.00-6.00   sec  70.0 MBytes   587 Mbits/sec    6   1.27 MBytes       
    [  5]   6.00-7.00   sec  68.8 MBytes   577 Mbits/sec    0   1.34 MBytes       
    [  5]   7.00-8.00   sec  68.8 MBytes   577 Mbits/sec    0   1.38 MBytes       
    [  5]   8.00-9.00   sec  70.0 MBytes   587 Mbits/sec    0   1.41 MBytes       
    [  5]   9.00-10.00  sec  68.8 MBytes   577 Mbits/sec    0   1.43 MBytes       
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ ID] Interval           Transfer     Bitrate         Retr
    [  5]   0.00-10.00  sec   686 MBytes   575 Mbits/sec   34             sender
    [  5]   0.00-10.06  sec   683 MBytes   570 Mbits/sec                  receiver
    
    iperf Done.
    frank@thinkpad:~$ iperf3 -R -c 192.168.3.213
    Connecting to host 192.168.3.213, port 5201
    Reverse mode, remote host 192.168.3.213 is sending
    [  5] local 192.168.0.100 port 59534 connected to 192.168.3.213 port 5201
    [ ID] Interval           Transfer     Bitrate
    [  5]   0.00-1.00   sec  84.4 MBytes   708 Mbits/sec                  
    [  5]   1.00-2.00   sec  91.7 MBytes   769 Mbits/sec                  
    [  5]   2.00-3.00   sec  91.5 MBytes   767 Mbits/sec                  
    [  5]   3.00-4.00   sec  90.7 MBytes   761 Mbits/sec                  
    [  5]   4.00-5.00   sec  91.5 MBytes   767 Mbits/sec                  
    [  5]   5.00-6.00   sec  91.2 MBytes   765 Mbits/sec                  
    [  5]   6.00-7.00   sec  91.2 MBytes   765 Mbits/sec                  
    [  5]   7.00-8.00   sec  92.1 MBytes   772 Mbits/sec                  
    [  5]   8.00-9.00   sec  90.3 MBytes   757 Mbits/sec                  
    [  5]   9.00-10.00  sec  91.9 MBytes   771 Mbits/sec                  
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ ID] Interval           Transfer     Bitrate         Retr
    [  5]   0.00-10.04  sec   910 MBytes   760 Mbits/sec    0             sender
    [  5]   0.00-10.00  sec   906 MBytes   760 Mbits/sec                  receiver
    
    iperf Done.
    

    Das geht dann nicht mehr volle Pulle. 🤔 Ok, nach dem Lesen diesen Threads einen kleinen Lüfter drauf gelegt. Man beachte, die Stromversorgung kommt vom ROCKPro64 🙂

    Gerade noch mal kontrolliert, der läuft volle Pulle.

    root@debian:/sys/class/hwmon/hwmon3# nano pwm1 
    

    gibt einen Wert von 255 aus, als Vollgas 😉

    IMG_20200922_120556_ergebnis.jpg

    -----------------------------------------------------------
    Server listening on 5201
    -----------------------------------------------------------
    Accepted connection from 192.168.3.8, port 59622
    [  5] local 192.168.3.213 port 5201 connected to 192.168.3.8 port 59624
    [ ID] Interval           Transfer     Bitrate
    [  5]   0.00-1.00   sec  76.3 MBytes   640 Mbits/sec                  
    [  5]   1.00-2.00   sec  96.5 MBytes   809 Mbits/sec                  
    [  5]   2.00-3.00   sec  95.2 MBytes   799 Mbits/sec                  
    [  5]   3.00-4.00   sec  92.7 MBytes   777 Mbits/sec                  
    [  5]   4.00-5.00   sec  96.8 MBytes   812 Mbits/sec                  
    [  5]   5.00-6.00   sec  95.1 MBytes   798 Mbits/sec                  
    [  5]   6.00-7.00   sec  95.1 MBytes   798 Mbits/sec                  
    [  5]   7.00-8.00   sec  95.2 MBytes   799 Mbits/sec                  
    [  5]   8.00-9.00   sec  92.3 MBytes   774 Mbits/sec                  
    [  5]   9.00-10.00  sec  94.6 MBytes   793 Mbits/sec                  
    [  5]  10.00-10.05  sec  4.86 MBytes   761 Mbits/sec                  
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ ID] Interval           Transfer     Bitrate
    [  5]   0.00-10.05  sec   935 MBytes   780 Mbits/sec                  receiver
    -----------------------------------------------------------
    Server listening on 5201
    -----------------------------------------------------------
    Accepted connection from 192.168.3.8, port 59626
    [  5] local 192.168.3.213 port 5201 connected to 192.168.3.8 port 59628
    [ ID] Interval           Transfer     Bitrate         Retr  Cwnd
    [  5]   0.00-1.00   sec  79.8 MBytes   669 Mbits/sec    0   3.00 MBytes       
    [  5]   1.00-2.00   sec  91.2 MBytes   765 Mbits/sec    0   3.00 MBytes       
    [  5]   2.00-3.00   sec  93.8 MBytes   786 Mbits/sec   14   2.24 MBytes       
    [  5]   3.00-4.00   sec  95.0 MBytes   797 Mbits/sec  286   1.69 MBytes       
    [  5]   4.00-5.00   sec  95.0 MBytes   797 Mbits/sec    0   1.79 MBytes       
    [  5]   5.00-6.00   sec  95.0 MBytes   797 Mbits/sec    0   1.87 MBytes       
    [  5]   6.00-7.00   sec  92.5 MBytes   776 Mbits/sec    0   1.93 MBytes       
    [  5]   7.00-8.00   sec  96.2 MBytes   807 Mbits/sec    0   1.97 MBytes       
    [  5]   8.00-9.00   sec  95.0 MBytes   797 Mbits/sec    0   2.00 MBytes       
    [  5]   9.00-10.00  sec  93.8 MBytes   786 Mbits/sec    0   2.01 MBytes       
    [  5]  10.00-10.04  sec  2.50 MBytes   531 Mbits/sec    0   2.01 MBytes       
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ ID] Interval           Transfer     Bitrate         Retr
    [  5]   0.00-10.04  sec   930 MBytes   777 Mbits/sec  300             sender
    -----------------------------------------------------------
    Server listening on 5201
    -----------------------------------------------------------
    

    Temperaturen ohne Lüfter

    /var/log# armbianmonitor -m
    Stop monitoring using [ctrl]-[c]
    Time        CPU    load %cpu %sys %usr %nice %io %irq   CPU  C.St.
    
    11:46:43: 1296MHz  0.04   0%   0%   0%   0%   0%   0% 48.6°C  0/6
    11:46:48:  408MHz  0.04   1%   0%   0%   0%   0%   0% 47.3°C  0/6
    11:46:53:  408MHz  0.04   1%   1%   0%   0%   0%   0% 47.3°C  0/6
    11:46:58:  600MHz  0.10   1%   1%   0%   0%   0%   0% 46.8°C  0/6
    

    Temperaturen mit Lüfter

    12:03:38:  408MHz  0.09   1%   1%   0%   0%   0%   0% 39.1°C  0/6
     12:03:43:  600MHz  0.08   1%   1%   0%   0%   0%   0% 38.2°C  0/6
     12:03:48:  408MHz  0.08   1%   1%   0%   0%   0%   0% 38.2°C  0/6
     12:03:54:  408MHz  0.07   1%   0%   0%   0%   0%   0% 39.5°C  0/6
     12:03:59:  408MHz  0.06   1%   1%   0%   0%   0%   0% 39.1°C  0/6
     12:04:04:  408MHz  0.06   1%   0%   0%   0%   0%   0% 38.2°C  0/6
    

    Damit dieser kleine Zwerg richtig läuft, müsste der wohl aus dem Gehäuse entfernt werden und sehr gut gekühlt werden. Hmm, mal sehen, es wird wenige Anwendungen geben wo ich das brauche.



  • Hier noch ein kleiner Benchmark mit dem armbianmonitor

    root@nanopi-r2s:/var/log# armbianmonitor -z
    Preparing benchmark. Be patient please...
    Vormals nicht ausgewähltes Paket p7zip wird gewählt.
    (Lese Datenbank ... 36012 Dateien und Verzeichnisse sind derzeit installiert.)
    Vorbereitung zum Entpacken von .../p7zip_16.02+dfsg-6_arm64.deb ...
    Entpacken von p7zip (16.02+dfsg-6) ...
    p7zip (16.02+dfsg-6) wird eingerichtet ...
    Trigger für man-db (2.8.5-2) werden verarbeitet ...
    
    7-Zip (a) [64] 16.02 : Copyright (c) 1999-2016 Igor Pavlov : 2016-05-21
    p7zip Version 16.02 (locale=de_DE.UTF-8,Utf16=on,HugeFiles=on,64 bits,4 CPUs LE)
    
    LE
    CPU Freq:   754  1293  1293  1292  1288  1292  1293  1292  1293
    
    RAM size:     979 MB,  # CPU hardware threads:   4
    RAM usage:    882 MB,  # Benchmark threads:      4
    
                           Compressing  |                  Decompressing
    Dict     Speed Usage    R/U Rating  |      Speed Usage    R/U Rating
             KiB/s     %   MIPS   MIPS  |      KiB/s     %   MIPS   MIPS
    
    22:       2165   319    660   2107  |      57100   396   1232   4872
    23:       2134   327    665   2175  |      54123   385   1218   4683
    24:       2107   337    673   2266  |      55039   397   1217   4832
    25:       1264   293    493   1444  |      49990   390   1140   4449
    ----------------------------------  | ------------------------------
    Avr:             319    623   1998  |              392   1202   4709
    Tot:             355    912   3353
    
    Monitoring output recorded while running the benchmark:
    
    Time        CPU    load %cpu %sys %usr %nice %io %irq   CPU  C.St.
    12:22:00: 1296MHz  0.26   1%   0%   0%   0%   0%   0% 42.7°C  0/6
    12:22:05:  408MHz  0.24   0%   0%   0%   0%   0%   0% 37.3°C  0/6
    12:22:10: 1296MHz  0.36   2%   0%   1%   0%   0%   0% 40.0°C  0/6
    12:22:15: 1296MHz  0.57  47%   1%  45%   0%   0%   0% 48.2°C  0/6
    12:22:21: 1296MHz  0.84  92%   1%  91%   0%   0%   0% 50.8°C  0/6
    12:22:26: 1296MHz  1.18  78%   2%  75%   0%   0%   0% 49.5°C  0/6
    12:22:33: 1296MHz  1.40  91%   2%  88%   0%   0%   0% 53.8°C  0/6
    12:22:38: 1296MHz  1.53  76%   2%  74%   0%   0%   0% 50.0°C  0/6
    12:22:43: 1296MHz  1.81  84%   2%  82%   0%   0%   0% 50.4°C  0/6
    12:22:48: 1296MHz  1.91  92%   3%  88%   0%   0%   0% 50.4°C  0/6
    12:22:53: 1296MHz  2.07  90%   2%  88%   0%   0%   0% 47.7°C  0/6
    12:22:59: 1296MHz  2.39  66%   3%  63%   0%   0%   0% 50.0°C  0/6
    12:23:04: 1296MHz  2.52  82%   2%  79%   0%   0%   0% 50.0°C  0/6
    12:23:09: 1296MHz  2.64  86%   2%  84%   0%   0%   0% 50.0°C  0/6
    Time        CPU    load %cpu %sys %usr %nice %io %irq   CPU  C.St.
    12:23:15: 1296MHz  2.58  93%   5%  87%   0%   0%   0% 50.0°C  0/6
    12:23:26: 1296MHz  3.11  97%  14%  82%   0%   0%   0% 52.1°C  0/6
    12:23:33: 1296MHz  3.47  89%  64%  23%   0%   0%   0% 50.8°C  0/6
    12:23:38: 1296MHz  3.51  89%  73%  15%   0%   0%   0% 50.8°C  0/6
    12:23:44: 1296MHz  3.55  84%  76%   7%   0%   0%   0% 52.5°C  0/6
    12:23:49: 1296MHz  3.51  73%  25%  47%   0%   0%   0%
    

    Ok, sieht ja doch nicht soo schlecht aus. Bei Rechenleistung hält er sich stabil bei 1296MHz.
    Das sollte dann am Limit sein.

    root@nanopi-r2s:/var/log# cat /etc/default/cpufrequtils
    ENABLE=true
    MIN_SPEED=408000
    MAX_SPEED=1296000
    GOVERNOR=ondemand


  • Speedtest meines Corsair Voyager GTX mit 120GB

    root@nanopi-r2s:/tmp# dd if=/dev/zero of=sd.img bs=1M count=4096 conv=fdatasync
    4096+0 Datensätze ein
    4096+0 Datensätze aus
    4294967296 bytes (4,3 GB, 4,0 GiB) copied, 122,096 s, 35,2 MB/s
    

    Also, an der Seite ist ein lausiger USB2- Port. Kann man also direkt vergessen 😉 Ich bin doch arg verwöhnt vom ROCKPro64 🙂

    Die SD-Karte

    root@nanopi-r2s:~# dd if=/dev/zero of=sd.img bs=1M count=4096 conv=fdatasync
    4096+0 Datensätze ein
    4096+0 Datensätze aus
    4294967296 bytes (4,3 GB, 4,0 GiB) copied, 276,401 s, 15,5 MB/s
    

    Ok, die ist aber langsam, da muss ich nochmal ran.

    Fazit

    Als Datengrab bitte unbedingt einen ROCKPro64 kaufen! Da geht wenigstens was. Aber, es kommt auf die Anwendung an und da habe ich ja was anderes mit dem NanoPi R2S vor.



  • Gerade, nach ein paar Tagen mal geschaut, ob er noch lebt 🙂

    Ja, bei angenehmen 45 Grad.

    Dann mal flott nachgesehen, ob es was Neues gibt.

    apt update && apt upgrade
    

    Ja, Debian Buster 10.6 🤓 Alles aktualisiert und mal nachgeschaut.

    frank@frank-MS-7C37:~$ ssh root@192.168.3.12
    root@192.168.3.12's password: 
     _   _                         _   ____  ____  ____  
    | \ | | __ _ _ __   ___  _ __ (_) |  _ \|___ \/ ___| 
    |  \| |/ _` | '_ \ / _ \| '_ \| | | |_) | __) \___ \ 
    | |\  | (_| | | | | (_) | |_) | | |  _ < / __/ ___) |
    |_| \_|\__,_|_| |_|\___/| .__/|_| |_| \_\_____|____/ 
                            |_|                          
    Welcome to Debian GNU/Linux 10 (buster) with Linux 5.8.11-rockchip64
    
    No end-user support: built from trunk
    
    System load:   3%           	Up time:       2 min		
    Memory usage:  11% of 979M   	IP:            192.168.3.12
    CPU temp:      49°C           	Usage of /:    20% of 29G    	
    
    Last login: Sat Sep 26 15:09:11 2020 from 192.168.0.100
    root@nanopi-r2s:~# cat /etc/debian_version
    10.6
    root@nanopi-r2s:~#


  • Ok, die Netwerkkonfiguration will nicht so wie ich. 😕

    Der Netzwerkmanager ist das Problem! Da ich den auf einem headless System nicht brauche, deaktivieren wir diesen.

    nano /etc/NetworkManager/NetworkManager.conf
    

    Da steht folgendes drin

    [main]
    dns=default
    rc-manager=file
    plugins=ifupdown,keyfile
    
    [ifupdown]
    managed=true
    

    Die letzte Zeile ändern wir in

    [ifupdown]
        managed=false
    

    Danach ein Neustart. Und siehe da, meine doppelten IP-Adressen sind auch weg.

    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether b2:b5:10:38:9e:76 brd ff:ff:ff:ff:ff:ff
        inet 192.168.3.12/24 brd 192.168.3.255 scope global dynamic eth0
           valid_lft 7116sec preferred_lft 7116sec
        inet6 2a02:908:1268:1d50:b0b5:xxxx:xxxx:xxxx/64 scope global dynamic mngtmpaddr 
           valid_lft 7185sec preferred_lft 585sec
        inet6 fe80::b0b5:10ff:fe38:xxxx/64 scope link 
           valid_lft forever preferred_lft forever
    

    Zur Kontrolle, eben nochmal neugestartet und nachgeschaut. Perfekt, passt jetzt.

    Das Firewall Script in den Autostart und dann mal die Tage schaue, wie er sich so macht.


Log in to reply
 

Diese Artikel könnten Dich auch interessieren.

  • 1
  • 3
  • 1
  • 4
  • 1
  • 1
  • 3
  • 3