• Da ich ja mit dem Proxmox recht zufrieden bin, habe ich mir mal wieder was einfallen lassen 😉 Ich stelle mirhier einen in die Wohnung, der dann einiges ersetzen soll und als Spielwiese dienen soll. Da so ein Proxmox nicht auf den ARM-Platinen läuft, muss was Neues her.

    Da ich aber ungerne jetzt irgendwas Gebrauchtes kaufen möchte und es auch von der Performance nicht in einem Jahr am Ende sein soll, habe ich folgendes rausgesucht.

    • Gehäuse TT Core V1
    • Netzteil TT Touchpower DPS G
    • MSI B550I Board
    • CPU AMD Ryzen5 5600G
    • 64GB RAM

    Das sollte ausreichen um einen Proxmox hier zu Hause zu befeuern 🙂 Was ich aktuell noch nicht weiß, wie ich das mit den Platten mache. Da muss ich noch mal drüber schlafen. Aktuell ist mal eine NVMe SSD Samsung 970 Pro mit 512GB RAM verbaut.

    Was heute auf so eine kleine Platine passt ist schon ordentlich.

    Ok, wir machen uns mal ans zusammenbauen.

    20211015_170110_ergebnis.jpg

    Fertig LOL Naja, ganz so einfach war es dann doch nicht. Das G oben, bei Prozessor, habe ich extra markiert. Der Prozessor hat ja ein Grafik Unit drin, das war auch Absicht, weil ich keine Grafikkarte kaufen wollte. Ich hatte aber im Vorfeld schon Bedenken, ob das so auch läuft. Hatte natürlich vorher sehr intensiv die Dokumentation gelesen und die CPU stand auch auf der Kompatibilitätsliste.

    Gut, eingeschaltet - kein Bild 😞 Ich hatte es ja erwartet..... BIOS lag hier auch schon rum, aber ich kam nicht an die Möglichkeiten dran um ein BIOS zu flashen. Hmm!?!? Mir fiel erst nichts ein, also habe ich die Dokumentation sehr intensiv gelesen. Das mache ich im Normalfall nie 😉

    Auf Seite 45 der Dokumentation die Erlösung, man konnte auch anders flashen. Nennt sich Update BIOS with Flash BIOS Button. Mein erster Versuch war erfolglos, also suchte ich bei Youtube Rat. Ich fand ein Video, was mir dann schnell meinen Fehler aufgezeigt hat. Ich habe immer versucht zu flashen, wenn der PC eingeschaltet war, das ist aber gar nicht nötig. Man braucht bei eingeschaltetem Netzteil nur den Button drücken und das Board flasht das BIOS was auf dem USB-Stick ist.

    20211015_180034_ergebnis.jpg

    Auf dem Bild seht ihr den USB Port zum Flashen und den Button. Eine echt praktische Sache und ohne diese Funktion wäre ich jetzt nicht weiter gekommen. Dann hätte ich erst eine andere CPU einbauen müssen usw. ....

    Nachdem das aktuellste BIOS drauf war, war ich optimistisch das die Kiste jetzt rennen sollte. Also, frisch ans Werk und wieder einschalten.

    20211015_160206_ergebnis.jpg

    Yeah, ich hatte ein Bild 🙏

    Danach den vorbereiteten USB-Stick mit Proxmox rein, durchstarten und installieren. Ging alles glatt.

    Erstes kurzes Fazit

    Das Board macht einen wirklich sehr guten Eindruck, klasse Ausstattung, die natürlich auch ihren Preis hat.

    • 2,5G LAN
    • WiFi 6

    Das WiFi wird auch erkannt. Muss ich bei Gelegenheit mal testen. Ist auch ein alter Bekannter, von dem ich hier schon ein paar PCIe-Karten am laufen habe.

    29:00.0 Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a)
    

    und

    3: wlp41s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
        link/ether a4:b1:c1:97:68:4b brd ff:ff:ff:ff:ff:ff
    

    Die AMD CPU sollte für das was ich vorhabe locker reichen.

    root@pve:~# lscpu
    Architecture:                    x86_64
    CPU op-mode(s):                  32-bit, 64-bit
    Byte Order:                      Little Endian
    Address sizes:                   48 bits physical, 48 bits virtual
    CPU(s):                          12
    On-line CPU(s) list:             0-11
    Thread(s) per core:              2
    Core(s) per socket:              6
    Socket(s):                       1
    NUMA node(s):                    1
    Vendor ID:                       AuthenticAMD
    CPU family:                      25
    Model:                           80
    Model name:                      AMD Ryzen 5 5600G with Radeon Graphics
    Stepping:                        0
    Frequency boost:                 enabled
    CPU MHz:                         3175.127
    CPU max MHz:                     4463.6709
    CPU min MHz:                     1400.0000
    BogoMIPS:                        7786.27
    Virtualization:                  AMD-V
    L1d cache:                       192 KiB
    L1i cache:                       192 KiB
    L2 cache:                        3 MiB
    L3 cache:                        16 MiB
    NUMA node0 CPU(s):               0-11
    

    Also 6 Cores mit 12 Threads. Und jetzt ist für heute Feierabend, Kiste läuft erst mal, der Rest folgt....

    20211015_165955_ergebnis.jpg

  • Referenced by  FrankM FrankM 
  • Referenced by  FrankM FrankM 

  • Einige Tage später, bin ich mit meinem neuen Projekt (grob) fertig. Der Rechner hostet jetzt eine Proxmox VE auf der eine VM mit pfSense läuft, die meinem Netzwerk als Sicherung dient. Dazu ist eine zusätzliche Netzwerkkarte in den freien Grafikkartenslot verbaut worden.

    Jo, es hatte schon seinen Grund einen AMD Ryzen5 5600G zu nehmen 😉

    10:00.0 Ethernet controller: Intel Corporation 82576 Gigabit Network Connection (rev 01)
    10:00.1 Ethernet controller: Intel Corporation 82576 Gigabit Network Connection (rev 01)
    

    Somit hatte ich die benötigten Netzwerkkarten für mein Setup.

    • WAN - Netzwerkschnittstelle auf dem Bord
    • LAN - Intel Corporation 82576
    • OPT1 - Intel Corporation 82576

    LAN ist das Netzwerk für meine Geräte, OPT1 ist mein Netzwerk für alle Geräte denen ich nicht besonders vertraue.

    • TV
    • FireTV
    • PS5
      usw.

    Das läuft auch mit guter Geschwindigkeit.

    speed.png

    Was mir hier richtig Zeit gekostet hatte, war ein Denkfehler im Konzept. Ich habe ja mein aktuelles NAS aufgelöst und hatte den ZFS-Pool des Proxmox dafür benutzt. Das ging auch, aber mir gefielen da einige Aspekte nicht.

    • lief im falschen Netz
    • auf dem Proxmox Host lief der NFS

    Suboptimal, das musste besser gehen. Also habe ich mich damit beschäftigt, wie man Festplatten an eine VM durchreicht. Das Ergebnis

    4ad18f09-4098-41c8-a92d-bb5fd3392999-grafik.png

    Aus diesen beiden Platten habe ich dann einen ZFS-Pool gemacht.

    root@debian1:~# zpool status
      pool: NAS
     state: ONLINE
      scan: resilvered 232K in 00:00:01 with 0 errors on Sun Oct 17 16:38:46 2021
    config:
    
    	NAME                                      STATE     READ WRITE CKSUM
    	NAS                                       ONLINE       0     0     0
    	  mirror-0                                ONLINE       0     0     0
    	    scsi-0QEMU_QEMU_HARDDISK_drive-scsi1  ONLINE       0     0     0
    	    scsi-0QEMU_QEMU_HARDDISK_drive-scsi2  ONLINE       0     0     0
    
    errors: No known data errors
    

    Warum ZFS? Kann ich auch nicht beantworten, da immer mehr das nutzen (Ubuntu, pfSense usw.) habe ich gedacht, wir probieren es mal aus. Da ZFS sehr speicherhungrig ist, was ich vorher wusste, hat die Kiste auch 64GB RAM (Host). Ich hoffe das langt. Die Debian VM läuft zur Zeit mit 4GB. Mal sehen, ob das in Zukunft ausreicht.

    root@debian1:~# free
                  gesamt       benutzt     frei      gemns.  Puffer/Cache verfügbar
    Speicher:    4025628      119896     3801808         508      103924     3732976
    Swap:         998396           0      998396
    

    Das Ganze ist jetzt fertig aufgebaut und das Gehäuse ist zugeschraubt. Verbaut sind aktuell

    • 2 * 4TB HDD ZFS-Pool Host
    • 2 * 2TB HDD ZFS-Pool für NAS (VM100)

    Nächster Schritt ist die Datensicherung des NAS und grundsätzlich die Vervollständigung der Konfiguration. Da habe ich bei der Testerei doch einiges ignoriert....

    20211018_111551_ergebnis.jpg

  • 5
  • 2
  • 1
  • 1
  • 2
  • 1
  • 1
  • 2